summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2009-03-27 18:43:46 +0100
committerGravatar Jonathan Beck2009-03-27 18:43:46 +0100
commitc99881e673b58efba240d6b9440768eace28b027 (patch)
tree16d521218a1a97ed726c9402229fd51341fe7745 /src/CMakeLists.txt
parent623314bb8de2a6ac71e44833d1f1a796274d3871 (diff)
downloadlibplist-c99881e673b58efba240d6b9440768eace28b027.tar.gz
libplist-c99881e673b58efba240d6b9440768eace28b027.tar.bz2
Complete and cleanup CMake build system.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8a79c22..4c0f843 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,6 +9,8 @@ SET(libplist_SRC
ADD_LIBRARY( plist SHARED ${libplist_SRC} )
TARGET_LINK_LIBRARIES( plist ${LIBXML2_LIBRARIES} ${GLIB2_LIBRARIES} )
+SET_TARGET_PROPERTIES( plist PROPERTIES VERSION ${LIBPLIST_LIBVERSION} )
+SET_TARGET_PROPERTIES( plist PROPERTIES SOVERSION ${LIBPLIST_SOVERSION} )
INSTALL(TARGETS plist
RUNTIME DESTINATION bin COMPONENT lib