summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2010-01-13 20:07:41 +0100
committerGravatar Martin Szulecki2010-01-13 20:16:41 +0100
commitc9b0721d65834ab6cf22453c39d6b9e97bd9db25 (patch)
treed918a9fcc483cd3e841e3cb5d9bb2a985ed33f42 /configure.ac
parent54e6e148642558b532b2d3ec704400229d1e6b50 (diff)
downloadsbmanager-c9b0721d65834ab6cf22453c39d6b9e97bd9db25.tar.gz
sbmanager-c9b0721d65834ab6cf22453c39d6b9e97bd9db25.tar.bz2
Added i18n support plus German translation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0082b5..d7136b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,11 +44,20 @@ AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -Werror")
AC_SUBST(GLOBAL_CFLAGS)
+# i18n
+
+GETTEXT_PACKAGE=sbmanager
+AC_SUBST([GETTEXT_PACKAGE])
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "$GETTEXT_PACKAGE", [Gettext package])
+AM_GLIB_GNU_GETTEXT
+IT_PROG_INTLTOOL([0.35.0])
+
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
AC_OUTPUT([
Makefile
data/Makefile
src/Makefile
+po/Makefile.in
])