summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hector Martin2009-04-26 20:33:29 +0200
committerGravatar Hector Martin2009-04-26 20:33:29 +0200
commit677fa91e376b98d871bb238ecb84685dd4f33ebd (patch)
tree0d04d069d16b7c3cba44cbeb6847ed7fc683442a /CMakeLists.txt
downloadusbmuxd-677fa91e376b98d871bb238ecb84685dd4f33ebd.tar.gz
usbmuxd-677fa91e376b98d871bb238ecb84685dd4f33ebd.tar.bz2
Hello, world!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..9e4345f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+PROJECT(usbmuxd)
+
+cmake_minimum_required(VERSION 2.6)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/Modules/")
+
+find_package(USB REQUIRED)
+include_directories(${USB_INCLUDE_DIRS})
+set(LIBS ${LIBS} ${USB_LIBRARIES})
+
+#set(CMAKE_VERBOSE_MAKEFILE ON)
+
+add_definitions(-Wall -O2)
+add_executable(usbmuxd usbmuxd.c usb-linux.c)
+target_link_libraries(usbmuxd ${LIBS})
+