summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2014-11-11 15:52:36 +0100
committerGravatar Nikias Bassen2014-12-02 19:22:25 +0100
commit34e6eeef656a205d4f65f128cb17bc81cca3b4d3 (patch)
tree3cbf63bc707654ffea3a28fd088e969e2edf8f68 /common/Makefile.am
parent816b587e32d894083bf884ca647e6c734b242e3f (diff)
downloadusbmuxd-34e6eeef656a205d4f65f128cb17bc81cca3b4d3.tar.gz
usbmuxd-34e6eeef656a205d4f65f128cb17bc81cca3b4d3.tar.bz2
Move utils to convenience library
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..b4a65b9
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,10 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir) -I$(top_srcdir)/src
+
+AM_CFLAGS = $(GLOBAL_CFLAGS) $(libplist_CFLAGS)
+AM_LDFLAGS = $(libplist_LIBS)
+
+noinst_LTLIBRARIES = libinternalcommon.la
+libinternalcommon_la_LIBADD =
+libinternalcommon_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined
+libinternalcommon_la_SOURCES = \
+ utils.c utils.h