summaryrefslogtreecommitdiffstats
path: root/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hector Martin2009-09-20 19:18:15 +0200
committerGravatar Hector Martin2009-10-03 17:16:24 +0200
commit8ea6dc804457d3ad02b5bc2017007f965359d8c5 (patch)
treefb08beb66949691bc6fddb56c2de1a0d0d377f74 /daemon/CMakeLists.txt
parente619fc9e4d90c9e86d1e05fe37ad6fbf284d6de8 (diff)
downloadusbmuxd-8ea6dc804457d3ad02b5bc2017007f965359d8c5.tar.gz
usbmuxd-8ea6dc804457d3ad02b5bc2017007f965359d8c5.tar.bz2
Require libusb-1.0.3 and hardcode explicit ZLP logic
1.0.3 has the 0-byte transaction fix. The saga continues on the libusb trac. Whenever they add the ZLP flag we can get rid of the 0-byte logic and just set it.
Diffstat (limited to 'daemon/CMakeLists.txt')
-rw-r--r--daemon/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/daemon/CMakeLists.txt b/daemon/CMakeLists.txt
index e5f9b11..8a5c417 100644
--- a/daemon/CMakeLists.txt
+++ b/daemon/CMakeLists.txt
@@ -6,25 +6,6 @@ include_directories (${CMAKE_SOURCE_DIR}/common)
include_directories (${CMAKE_SOURCE_DIR}/daemon)
include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)
-include(CheckConstantExists)
-set(CMAKE_REQUIRED_INCLUDES ${USB_INCLUDE_DIRS})
-check_constant_exists(LIBUSB_TRANSFER_ZERO_PACKET libusb.h HAVE_LIBUSB_ZLP)
-
-if(NOT HAVE_LIBUSB_ZLP)
- message("
-================================================================================
-==================================== WARNING ===================================
-================================================================================
-Your libusb is missing proper Zero Length Packet support! If you are using a
-recent libusb Git, things may or may not work. If you are using libusb 1.0.2 or
-earlier, things will definitely not work properly.
-
-Please apply the patch in the contrib/ directory to your libusb 1.0 tree.
-================================================================================
-")
- add_definitions(-DEXPLICIT_ZLP_TRANSACTION)
-endif(NOT HAVE_LIBUSB_ZLP)
-
add_definitions(-Wall -O2 -g -DUSBMUXD_DAEMON -DUSBMUXD_VERSION="${USBMUXD_VERSION}")
add_executable(usbmuxd main.c usb-linux.c log.c ../common/utils.c device.c client.c)
target_link_libraries(usbmuxd ${LIBS})