summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Cerrato Renaud2010-06-10 10:41:30 +0200
committerGravatar Hector Martin2010-06-13 19:38:39 +0200
commit63ffaef5b9ba6225d2106f9d4ec07dd318163287 (patch)
tree20e27ae61fdce88281cba12b2423088e7befe935 /libusbmuxd/CMakeLists.txt
parent713cfb3d145f9db242138405f16d4ab225e8ba04 (diff)
downloadusbmuxd-63ffaef5b9ba6225d2106f9d4ec07dd318163287.tar.gz
usbmuxd-63ffaef5b9ba6225d2106f9d4ec07dd318163287.tar.bz2
Fix cygwin builds
- libusbmuxd/CMakeLists.txt : there was a neglect into install rules, for DLL, RUNTIME was missing. - libusbmuxd.c : added __CYGWIN__ conditionnal compilation checks to force regular socket instead of UNIX sockets on CYGWIN platform.
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index 6bded04..c8f2cb4 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -21,6 +21,7 @@ set_target_properties(libusbmuxd PROPERTIES VERSION ${LIBUSBMUXD_VERSION})
set_target_properties(libusbmuxd PROPERTIES SOVERSION ${LIBUSBMUXD_SOVERSION})
install(TARGETS libusbmuxd
+ RUNTIME DESTINATION bin
ARCHIVE DESTINATION lib${LIB_SUFFIX}
LIBRARY DESTINATION lib${LIB_SUFFIX}
)