summaryrefslogtreecommitdiffstats
path: root/usbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2009-08-25 03:26:22 +0200
committerGravatar Nikias Bassen2009-08-25 03:26:22 +0200
commit4711a2b493f76561e9803bf7e8be77186f3e7798 (patch)
tree339684fe1b996e01047c3eb220a8e22e4491c5e2 /usbmuxd/CMakeLists.txt
parentde30ca5d5c98a8cbee3d8748601519e2263b3e1d (diff)
downloadusbmuxd-4711a2b493f76561e9803bf7e8be77186f3e7798.tar.gz
usbmuxd-4711a2b493f76561e9803bf7e8be77186f3e7798.tar.bz2
Renamed directory 'usbmuxd' to more suitable 'daemon'.
Diffstat (limited to 'usbmuxd/CMakeLists.txt')
-rw-r--r--usbmuxd/CMakeLists.txt32
1 files changed, 0 insertions, 32 deletions
diff --git a/usbmuxd/CMakeLists.txt b/usbmuxd/CMakeLists.txt
deleted file mode 100644
index f95727c..0000000
--- a/usbmuxd/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
-find_package(USB REQUIRED)
-include_directories(${USB_INCLUDE_DIRS})
-set(LIBS ${LIBS} ${USB_LIBRARIES})
-
-include_directories (${CMAKE_SOURCE_DIR}/common)
-include_directories (${CMAKE_SOURCE_DIR}/usbmuxd)
-include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)
-
-include(CheckConstantExists)
-set(CMAKE_REQUIRED_INCLUDES ${USB_INCLUDE_DIRS})
-check_constant_exists(LIBUSB_TRANSFER_ZERO_PACKET libusb.h HAVE_LIBUSB_ZLP)
-
-if(NOT HAVE_LIBUSB_ZLP)
- message("
-================================================================================
-==================================== WARNING ===================================
-================================================================================
-Your libusb is missing proper Zero Length Packet support! If you are using a
-recent libusb Git, things may or may not work. If you are using libusb 1.0.2 or
-earlier, things will definitely not work properly.
-
-Please apply the patch in the contrib/ directory to your libusb 1.0 tree.
-================================================================================
-")
- add_definitions(-DEXPLICIT_ZLP_TRANSACTION)
-endif(NOT HAVE_LIBUSB_ZLP)
-
-add_definitions(-Wall -O2 -g -DUSBMUXD_DAEMON)
-add_executable(usbmuxd main.c usb-linux.c log.c ../common/utils.c device.c client.c)
-target_link_libraries(usbmuxd ${LIBS})
-
-install(TARGETS usbmuxd RUNTIME DESTINATION sbin)