summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7dddfd2..5f0a6a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,13 @@ if(CMAKE_C_FLAGS STREQUAL "")
endif()
option(WITH_USBMUXD "Build usbmux daemon (usbmuxd)" ON)
+if(WIN32 AND WITH_USBMUXD)
+ message("** NOTE: usbmuxd cannot be built on WIN32 due to missing libusb-1.0 support!")
+ message(" If you need your own usbmuxd you have to use usbmuxd-legacy which works")
+ message(" with libusb-0.1; otherwise just use the one that ships with iTunes.")
+ message(" Building of usbmuxd has been disabled.")
+ set(WITH_USBMUXD OFF)
+endif()
if(WITH_USBMUXD)
message("-- Will build usbmuxd: YES")
else()