summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93fa715..8ed2e37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ set(LIBUSBMUXD_SOVERSION "1")
message("-- Configuring usbmuxd v${VERSION_TAG}")
if(NOT DEFINED LIB_SUFFIX)
- if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ if(CMAKE_SIZEOF_VOID_P EQUAL 8 AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
set(LIB_SUFFIX "64" CACHE STRING "Define suffix of library directory name (32/64)" )
else()
set(LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (32/64)" )
@@ -67,7 +67,7 @@ add_definitions(-Wall)
add_subdirectory (libusbmuxd)
if (WITH_USBMUXD)
add_subdirectory (daemon)
- if (NOT WIN32 AND NOT APPLE)
+ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
add_subdirectory (udev)
endif()
endif()