summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..b4a65b9
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,10 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir) -I$(top_srcdir)/src
+
+AM_CFLAGS = $(GLOBAL_CFLAGS) $(libplist_CFLAGS)
+AM_LDFLAGS = $(libplist_LIBS)
+
+noinst_LTLIBRARIES = libinternalcommon.la
+libinternalcommon_la_LIBADD =
+libinternalcommon_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined
+libinternalcommon_la_SOURCES = \
+ utils.c utils.h