summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index 236cca3..0d7d897 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -7,6 +7,9 @@ find_library (PTHREAD pthread)
if (HAVE_PLIST)
message("-- libusbmuxd will be built with protocol version 1 support")
endif()
+if(WIN32)
+ set(OPT_LIBS ${OPT_LIBS} ws2_32)
+endif()
target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT} ${OPT_LIBS})
# 'lib' is a UNIXism, the proper CMake target is usbmuxd