summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index 402d726..a3d5fbe 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -1,10 +1,14 @@
include_directories (${CMAKE_SOURCE_DIR}/common)
find_package(Threads)
+
+option(WANT_INOTIFY "Build with inotify support" ON)
+if (WANT_INOTIFY)
find_package(Inotify)
if (INOTIFY_FOUND)
add_definitions("-DHAVE_INOTIFY")
message("-- libusbmuxd will be built with inotify support")
endif()
+endif(WANT_INOTIFY)
add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
find_library (PTHREAD pthread)