summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index d275169..236cca3 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -3,7 +3,11 @@ find_package(Threads)
add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
find_library (PTHREAD pthread)
-target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT})
+
+if (HAVE_PLIST)
+ message("-- libusbmuxd will be built with protocol version 1 support")
+endif()
+target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT} ${OPT_LIBS})
# 'lib' is a UNIXism, the proper CMake target is usbmuxd
# But we can't use that due to the conflict with the usbmuxd daemon,