summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index d062f23..d275169 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -1,8 +1,10 @@
include_directories (${CMAKE_SOURCE_DIR}/common)
+find_package(Threads)
-add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ../common/utils.c)
+add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
find_library (PTHREAD pthread)
-target_link_libraries (libusbmuxd ${PTHREAD})
+target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT})
+
# 'lib' is a UNIXism, the proper CMake target is usbmuxd
# But we can't use that due to the conflict with the usbmuxd daemon,
# so instead change the library output base name to usbmuxd here