summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index accdbc4..cb0d259 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -6,6 +6,8 @@ add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ../common/utils.c)
# But we can't use that due to the conflict with the usbmuxd daemon,
# so instead change the library output base name to usbmuxd here
set_target_properties(libusbmuxd PROPERTIES OUTPUT_NAME usbmuxd)
+set_target_properties(libusbmuxd PROPERTIES VERSION ${LIBUSBMUXD_VERSION})
+set_target_properties(libusbmuxd PROPERTIES SOVERSION ${LIBUSBMUXD_VERSION})
install(TARGETS libusbmuxd
ARCHIVE DESTINATION lib