summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ae4e76..9158682 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,3 +4,12 @@ SUBDIRS = libcnary src include tools $(CYTHON_SUB) test
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libplist.pc libplist++.pc
+
+docs/html: $(top_builddir)/doxygen.cfg $(top_srcdir)/include/plist/*.h
+ rm -rf docs
+ doxygen doxygen.cfg
+
+docs: doxygen.cfg docs/html
+
+clean-local:
+ rm -rf docs