summaryrefslogtreecommitdiffstats
path: root/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2010-05-24 18:57:10 +0200
committerGravatar Nikias Bassen2010-05-26 01:39:28 +0200
commit6cb505257ff848aa7ead80b60b575effc3a915fa (patch)
tree941978b9186158ea2775f50c5929f9e8b88764be /daemon/CMakeLists.txt
parent847eaeba69de3b22e5d65b3a98311655876df80e (diff)
downloadusbmuxd-6cb505257ff848aa7ead80b60b575effc3a915fa.tar.gz
usbmuxd-6cb505257ff848aa7ead80b60b575effc3a915fa.tar.bz2
Add protocol version 1 (plist based) support using libplist
Diffstat (limited to 'daemon/CMakeLists.txt')
-rw-r--r--daemon/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/daemon/CMakeLists.txt b/daemon/CMakeLists.txt
index 6593deb..48ff0c6 100644
--- a/daemon/CMakeLists.txt
+++ b/daemon/CMakeLists.txt
@@ -1,7 +1,9 @@
find_package(USB REQUIRED)
include_directories(${USB_INCLUDE_DIRS})
-set(LIBS ${LIBS} ${USB_LIBRARIES})
-
+set(LIBS ${LIBS} ${USB_LIBRARIES} ${OPT_LIBS})
+if(HAVE_PLIST)
+ message("-- usbmuxd will be built with protocol version 1 support")
+endif()
include_directories (${CMAKE_SOURCE_DIR}/common)
include_directories (${CMAKE_SOURCE_DIR}/daemon)
include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)