summaryrefslogtreecommitdiffstats
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
new file mode 100644
index 0000000..6626d60
--- /dev/null
+++ b/systemd/Makefile.am
@@ -0,0 +1,21 @@
+edit = \
+ $(SED) -r \
+ -e 's|@sbindir[@]|$(sbindir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ < $< > $@ || rm $@
+
+if HAVE_SYSTEMD
+
+systemdsystemunit_DATA = \
+ usbmuxd.service
+
+usbmuxd.service: usbmuxd.service.in
+ $(edit)
+
+EXTRA_DIST = \
+ usbmuxd.service.in
+
+CLEANFILES = \
+ usbmuxd.service
+
+endif