summaryrefslogtreecommitdiffstats
path: root/axiom/configure.ac
diff options
context:
space:
mode:
authorGravatar gmcdonald2010-02-13 01:32:03 +0000
committerGravatar gmcdonald2010-02-13 01:32:03 +0000
commit0425aadc78680e53000fd0108b540d6eca048516 (patch)
tree8ec7ab8e015d454c5ec586dfc91e05a2dce1cfc0 /axiom/configure.ac
downloadaxis2c-0425aadc78680e53000fd0108b540d6eca048516.tar.gz
axis2c-0425aadc78680e53000fd0108b540d6eca048516.tar.bz2
Moving axis svn, part of TLP move INFRA-2441
git-svn-id: http://svn.apache.org/repos/asf/axis/axis2/c/core/trunk@909681 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'axiom/configure.ac')
-rw-r--r--axiom/configure.ac179
1 files changed, 179 insertions, 0 deletions
diff --git a/axiom/configure.ac b/axiom/configure.ac
new file mode 100644
index 0000000..6802fb9
--- /dev/null
+++ b/axiom/configure.ac
@@ -0,0 +1,179 @@
+dnl run autogen.sh to generate the configure script.
+
+AC_PREREQ(2.59)
+
+AC_INIT(axis2_axiom-src, 1.6.0)
+AC_CANONICAL_SYSTEM
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE
+AC_PREFIX_DEFAULT(/usr/local/axis2_axiom)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_CPP
+AC_PROG_LIBTOOL
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
+dnl check for flavours of varargs macros (test from GLib)
+AC_MSG_CHECKING(for ISO C99 varargs macros in C)
+AC_TRY_COMPILE([],[
+int a(int p1, int p2, int p3);
+#define call_a(...) a(1,__VA_ARGS__)
+call_a(2,3);
+],axis2c_have_iso_c_varargs=yes,axis2c_have_iso_c_varargs=no)
+AC_MSG_RESULT($axis2c_have_iso_c_varargs)
+
+AC_MSG_CHECKING(for GNUC varargs macros)
+AC_TRY_COMPILE([],[
+int a(int p1, int p2, int p3);
+#define call_a(params...) a(1,params)
+call_a(2,3);
+],axis2c_have_gnuc_varargs=yes,axis2c_have_gnuc_varargs=no)
+AC_MSG_RESULT($axis2c_have_gnuc_varargs)
+
+dnl Output varargs tests
+if test x$axis2c_have_iso_c_varargs = xyes; then
+ AC_DEFINE(HAVE_ISO_VARARGS,1,[Have ISO C99 varargs macros])
+fi
+if test x$axis2c_have_gnuc_varargs = xyes; then
+ AC_DEFINE(HAVE_GNUC_VARARGS,1,[Have GNU-style varargs macros])
+fi
+
+dnl Checks for libraries.
+AC_CHECK_LIB(dl, dlopen)
+AC_CHECK_LIB(z, inflate)
+
+#CFLAGS="$CFLAGS -ansi -Wall -D_LARGEFILE64_SOURCE -Wno-implicit-function-declaration"
+CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+if test "$GCC" = "yes"; then
+ CFLAGS="$CFLAGS -ansi -Werror -Wall -Wno-implicit-function-declaration "
+fi
+
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdio.h stdlib.h string.h])
+AC_CHECK_HEADERS([sys/socket.h])
+AC_CHECK_HEADERS([linux/if.h],[],[],
+[
+#if HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#endif
+])
+
+dnl This is a check to see if we are running MacOS X
+dnl It may be better to do a Darwin check
+AC_CHECK_HEADER([sys/appleapiopts.h],
+ [AC_DEFINE([IS_MACOSX],[1],[Define to 1 if compiling on MacOS X])],
+ [])
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+dnl AC_C_CONST
+
+dnl Checks for library functions.
+dnl AC_FUNC_MALLOC
+dnl AC_FUNC_REALLOC
+#AC_CHECK_FUNCS([memmove])
+
+AC_MSG_CHECKING(whether to build xpath)
+AC_ARG_ENABLE(xpath, [ --enable-xpath build xpath. default=yes],
+[ case "${enableval}" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ XPATH_DIR="xpath"
+
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+ XPATH_DIR="xpath"
+)
+
+
+AC_MSG_CHECKING(whether to build guththila xml parser library)
+AC_ARG_ENABLE(guththila, [ --enable-guththila build guththila xml parser library wrapper. default=yes],
+[ case "${enableval}" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ WRAPPER_DIR="guththila"
+
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+ WRAPPER_DIR="guththila"
+)
+
+AC_MSG_CHECKING(whether to build libxml2 xml parser library)
+AC_ARG_ENABLE(libxml2, [ --enable-libxml2 build libxml2 xml parser library wrapper. default=no],
+[ case "${enableval}" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -DAXIS2_LIBXML2_ENABLED"
+ WRAPPER_DIR="libxml2"
+ PKG_CHECK_MODULES(LIBXML2, libxml-2.0)
+
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+
+AC_MSG_CHECKING(whether to build tests)
+AC_ARG_ENABLE(tests, [ --enable-tests build tests. default=no],
+[ case "${enableval}" in
+ yes)
+ AC_MSG_RESULT(yes)
+ TESTDIR="test"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ TESTDIR=""
+
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+ TESTDIR=""
+)
+
+PKG_PROG_PKG_CONFIG(0.15)
+CFLAGS="$CFLAGS $GUTHTHILA_CFLAGS"
+VERSION_NO="6:0:6"
+
+AC_SUBST(VERSION_NO)
+AC_SUBST(LIBXML2_CFLAGS)
+AC_SUBST(LIBXML2_LIBS)
+AC_SUBST(WRAPPER_DIR)
+AC_SUBST(GUTHTHILA_LIBS)
+AC_SUBST(TESTDIR)
+AC_SUBST(XPATH_DIR)
+
+AC_CONFIG_FILES([Makefile \
+ src/Makefile \
+ src/parser/Makefile \
+ src/parser/libxml2/Makefile \
+ src/parser/guththila/Makefile \
+ src/soap/Makefile \
+ src/om/Makefile \
+ src/util/Makefile \
+ src/attachments/Makefile \
+ src/xpath/Makefile \
+ test/Makefile \
+ test/om/Makefile \
+ test/soap/Makefile \
+ test/util/Makefile \
+ test/xpath/Makefile \
+ include/Makefile
+ ])
+
+AC_OUTPUT