summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar shankar2010-03-03 11:08:18 +0000
committerGravatar shankar2010-03-03 11:08:18 +0000
commit48badcb5665355ebe31760399c5898951603afdc (patch)
treedb34ebbbd699e5cf511f6e8748d086dc287b4a48 /configure.ac
parent6f57b8cd3a6d0d80cbc0afa6d5c418c513f89ab9 (diff)
downloadaxis2c-48badcb5665355ebe31760399c5898951603afdc.tar.gz
axis2c-48badcb5665355ebe31760399c5898951603afdc.tar.bz2
fixing issue AXIS2C-1240
git-svn-id: http://svn.apache.org/repos/asf/axis/axis2/c/core/trunk@918409 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 28 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 432887a..0987384 100644
--- a/configure.ac
+++ b/configure.ac
@@ -374,25 +374,39 @@ AC_ARG_ENABLE(multi-thread, [ --enable-multi-thread
)
AC_MSG_CHECKING(whether to use openssl)
-AC_ARG_ENABLE(openssl, [ --enable-openssl
- enable OpenSSL support in client transport (default=no)],
-[ case "${enableval}" in
+AC_ARG_WITH(openssl,
+[ --with-openssl[=PATH] Find the openssl header files in 'PATH'.
+ If this option is given, Openssl support in transport will be enabled.
+ 'PATH' should point to openssl installation location.
+ If you omit the '=PATH' part completely, the configure script will search
+ '/usr/include/openssl' for openssl headers.],
+[ case "$withval" in
no)
AC_MSG_RESULT(no)
- CFLAGS="$CFLAGS"
- CPPFLAGS="$CPPFLAGS"
ssl_enabled=false
;;
*)
AC_MSG_RESULT(yes)
- CFLAGS="$CFLAGS -DAXIS2_SSL_ENABLED"
- CPPFLAGS="$CPPFLAGS -DAXIS2_SSL_ENABLED"
- ssl_enabled=true
+ dnl Find openssl dir in the path
+ if test -d $withval; then
+ opensslinc="-I$withval/include"
+ openssllib="-L$withval/lib"
+ CFLAGS="$CFLAGS -DAXIS2_SSL_ENABLED"
+ CPPFLAGS="$CPPFLAGS -DAXIS2_SSL_ENABLED"
+ ssl_enabled=true
+ dnl else find the include dir in /usr/local/openssl
+ elif test -d '/usr/include/openssl'; then
+ CFLAGS="$CFLAGS -DAXIS2_SSL_ENABLED"
+ CPPFLAGS="$CPPFLAGS -DAXIS2_SSL_ENABLED"
+ opensslinc="-I/usr/include/openssl"
+ openssllib=""
+ ssl_enabled=true
+ else
+ AC_MSG_ERROR(could not find openssl. stop)
+ fi
;;
esac ],
AC_MSG_RESULT(no)
- CFLAGS="$CFLAGS"
- CPPFLAGS="$CPPFLAGS"
)
AC_MSG_CHECKING(whether to use libcurl)
@@ -419,6 +433,8 @@ AC_ARG_ENABLE(libcurl, [ --enable-libcurl
APACHE2INC=$apache2inc
+OPENSSLINC=$opensslinc
+OPENSSLLIB=$openssllib
IKSEMELINC=$iksemelinc
APRINC=$aprinc
VERSION_NO="6:0:6"
@@ -426,6 +442,8 @@ QPID_HOME=$qpidhome
AC_SUBST(VERSION_NO)
AC_SUBST(APACHE2INC)
+AC_SUBST(OPENSSLINC)
+AC_SUBST(OPENSSLLIB)
AC_SUBST(APRINC)
AC_SUBST(DICLIENT_DIR)
AC_SUBST(TESTDIR)