summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar shankar2010-03-10 05:22:10 +0000
committerGravatar shankar2010-03-10 05:22:10 +0000
commit79eb37f48200f85832fad2205bfb5e2ae54eda96 (patch)
treef5b77476f7fc16ac47b5aef258883af20ca07e7a /configure.ac
parentb31c0c92e7b148c30f44b100df1ccebf082cfecc (diff)
downloadaxis2c-79eb37f48200f85832fad2205bfb5e2ae54eda96.tar.gz
axis2c-79eb37f48200f85832fad2205bfb5e2ae54eda96.tar.bz2
adding location for apache2 and apr
git-svn-id: http://svn.apache.org/repos/asf/axis/axis2/c/core/trunk@921229 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 43d89a3..8ff3bb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,7 +262,7 @@ AC_ARG_WITH(apache2,
If this option is given, the Apache2 httpd module would be built.
'PATH' should point to Apache2 httpd include files location.
If you omit the '=PATH' part completely, the configure script will search
- '/usr/include/apache2' for Apache2 headers.],
+ '/usr/include/apache2' or '/usr/include/httpd' for Apache2 headers.],
[ case "$withval" in
no)
AC_MSG_RESULT(no)
@@ -276,6 +276,8 @@ AC_ARG_WITH(apache2,
dnl else find the apache2 include dir in /usr/local/apache2
elif test -d '/usr/include/apache2'; then
apache2inc="-I/usr/include/apache2"
+ elif test -d '/usr/include/httpd'; then
+ apache2inc="-I/usr/include/httpd"
else
AC_MSG_ERROR(could not find apache2. stop)
fi
@@ -293,7 +295,7 @@ AC_ARG_WITH(apr,
In that case, to build Apache2 httpd module, this option is also required.
'PATH' should point to APR include files location.
If you omit the '=PATH' part completely, the configure script will search
- '/usr/include/apr-0' for APR headers.],
+ '/usr/include/apr-0' or '/usr/include/apr-1' for APR headers.],
[ case "$withval" in
no)
AC_MSG_RESULT(no)
@@ -306,6 +308,8 @@ AC_ARG_WITH(apr,
dnl else find the apache2 include dir in /usr/local/apache2
elif test -d '/usr/include/apr-0'; then
aprinc="-I/usr/include/apr-0"
+ elif test -d '/usr/include/apr-1'; then
+ aprinc="-I/usr/include/apr-1"
else
AC_MSG_ERROR(could not find apr. stop)
fi