summaryrefslogtreecommitdiffstats
path: root/src/core/deployment/Makefile.am
diff options
context:
space:
mode:
authorGravatar gmcdonald2010-02-13 01:32:03 +0000
committerGravatar gmcdonald2010-02-13 01:32:03 +0000
commit0425aadc78680e53000fd0108b540d6eca048516 (patch)
tree8ec7ab8e015d454c5ec586dfc91e05a2dce1cfc0 /src/core/deployment/Makefile.am
downloadaxis2c-0425aadc78680e53000fd0108b540d6eca048516.tar.gz
axis2c-0425aadc78680e53000fd0108b540d6eca048516.tar.bz2
Moving axis svn, part of TLP move INFRA-2441
git-svn-id: http://svn.apache.org/repos/asf/axis/axis2/c/core/trunk@909681 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/core/deployment/Makefile.am')
-rw-r--r--src/core/deployment/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/core/deployment/Makefile.am b/src/core/deployment/Makefile.am
new file mode 100644
index 0000000..7099839
--- /dev/null
+++ b/src/core/deployment/Makefile.am
@@ -0,0 +1,38 @@
+noinst_LTLIBRARIES = libaxis2_deployment.la
+
+noinst_HEADERS = axis2_deployment.h \
+ axis2_arch_file_data.h \
+ axis2_arch_reader.h \
+ axis2_conf_builder.h \
+ axis2_dep_engine.h \
+ axis2_desc_builder.h \
+ axis2_module_builder.h \
+ axis2_repos_listener.h \
+ axis2_svc_builder.h \
+ axis2_svc_grp_builder.h \
+ axis2_ws_info.h \
+ axis2_ws_info_list.h
+
+libaxis2_deployment_la_SOURCES =phases_info.c \
+ desc_builder.c \
+ arch_reader.c \
+ dep_engine.c \
+ arch_file_data.c \
+ ws_info.c \
+ ws_info_list.c \
+ svc_builder.c \
+ svc_grp_builder.c \
+ module_builder.c \
+ conf_builder.c \
+ repos_listener.c \
+ conf_init.c
+
+INCLUDES = -I$(top_builddir)/include \
+ -I$(top_builddir)/src/core/description \
+ -I$(top_builddir)/src/core/engine \
+ -I$(top_builddir)/src/core/phaseresolver \
+ -I$(top_builddir)/src/core/deployment \
+ -I$(top_builddir)/src/core/util \
+ -I$(top_builddir)/axiom/include \
+ -I$(top_builddir)/neethi/include \
+ -I$(top_builddir)/util/include