summaryrefslogtreecommitdiffstats
path: root/axiom/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'axiom/configure.ac')
-rw-r--r--axiom/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/axiom/configure.ac b/axiom/configure.ac
index 09ba267..d3cdd1f 100644
--- a/axiom/configure.ac
+++ b/axiom/configure.ac
@@ -61,9 +61,22 @@ AC_CHECK_LIB(z, inflate)
CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
if test "$GCC" = "yes"; then
- CFLAGS="$CFLAGS -ansi -Werror -Wall -Wno-implicit-function-declaration "
+ CFLAGS="$CFLAGS -ansi -Wall -Wno-implicit-function-declaration "
fi
+AC_MSG_CHECKING(whether to set -Werror)
+AC_ARG_ENABLE(werror, [ --disable-werror do not treat warnings as errors during build],
+[ case "${enableval}" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -Werror"
+ ;;
+ esac ],
+)
+
dnl Checks for header files.
AC_HEADER_STDC