summaryrefslogtreecommitdiffstats
path: root/neethi/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'neethi/configure.ac')
-rw-r--r--neethi/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/neethi/configure.ac b/neethi/configure.ac
index f6e1825..4f20d36 100644
--- a/neethi/configure.ac
+++ b/neethi/configure.ac
@@ -46,9 +46,22 @@ AC_CHECK_LIB(dl, dlopen)
CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
if test "$GCC" = "yes"; then
- CFLAGS="$CFLAGS -ansi -Wall -Werror -Wno-implicit-function-declaration "
+ CFLAGS="$CFLAGS -ansi -Wall -Wno-implicit-function-declaration "
fi
+AC_MSG_CHECKING(whether to set -Werror)
+AC_ARG_ENABLE(werror, [ --disable-werror do not treat warnings as errors during build],
+[ case "${enableval}" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -Werror"
+ ;;
+ esac ],
+)
+
dnl Checks for header files.
AC_HEADER_STDC