summaryrefslogtreecommitdiffstats
path: root/samples/client/ntlm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'samples/client/ntlm/Makefile.am')
-rw-r--r--samples/client/ntlm/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/samples/client/ntlm/Makefile.am b/samples/client/ntlm/Makefile.am
new file mode 100644
index 0000000..ef0b9a2
--- /dev/null
+++ b/samples/client/ntlm/Makefile.am
@@ -0,0 +1,33 @@
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed with
+# this work for additional information regarding copyright ownership.
+# The ASF licenses this file to You under the Apache License, Version 2.0
+# (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+prgbindir=$(prefix)/samples/bin
+prgbin_PROGRAMS = ntlm_client
+AM_CFLAGS = -g -O2
+ntlm_client_SOURCES = client.c
+
+LINK_FLAGS = $(LDFLAGS) \
+ -L$(AXIS2C_HOME)/lib \
+ -laxutil \
+ -laxis2_axiom \
+ -laxis2_engine \
+ -laxis2_parser \
+ -laxis2_http_sender \
+ -laxis2_http_receiver \
+ -laxis2_ntlm \
+ $(GUTHTHILA_LIBS)
+
+ntlm_client_LDADD = $(LINK_FLAGS)
+INCLUDES = @AXIS2INC@
+