summaryrefslogtreecommitdiffstats
path: root/src/core/transport/http/sender/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/transport/http/sender/Makefile.am')
-rw-r--r--src/core/transport/http/sender/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/core/transport/http/sender/Makefile.am b/src/core/transport/http/sender/Makefile.am
index 399ed39..71026fc 100644
--- a/src/core/transport/http/sender/Makefile.am
+++ b/src/core/transport/http/sender/Makefile.am
@@ -16,10 +16,12 @@ endif
if AXIS2_SSL_ENABLED
SSL_SOURCES = ssl/ssl_stream.c\
ssl/ssl_utils.c
-SSL_LIBS = -lssl -lcrypto
+SSL_LIBS = @OPENSSLLIB@ -lssl -lcrypto
+SSL_INC = @OPENSSLINC@
else
SSL_SOURCES=
SSL_LIBS=
+SSL_INC =
endif
libaxis2_http_sender_la_SOURCES = http_transport_sender.c \
@@ -48,4 +50,5 @@ INCLUDES = -I$(top_builddir)/include \
-I$(top_builddir)/src/core/engine \
-I$(top_builddir)/src/core/deployment \
-I$(top_builddir)/util/include \
- -I$(top_builddir)/axiom/include
+ -I$(top_builddir)/axiom/include \
+ $(SSL_INC)