summaryrefslogtreecommitdiffstats
path: root/test/core/engine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/core/engine/Makefile.am')
-rw-r--r--test/core/engine/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/test/core/engine/Makefile.am b/test/core/engine/Makefile.am
new file mode 100644
index 0000000..e6d41de
--- /dev/null
+++ b/test/core/engine/Makefile.am
@@ -0,0 +1,25 @@
+TESTS = test_engine
+check_PROGRAMS = test_engine
+noinst_PROGRAMS = test_engine
+SUBDIRS =
+AM_CFLAGS = -g -pthread
+test_engine_SOURCES = test_engine.c
+
+
+test_engine_LDADD = \
+ ../../../util/src/libaxutil.la \
+ ../../../axiom/src/om/libaxis2_axiom.la \
+ ../../../axiom/src/parser/$(WRAPPER_DIR)/libaxis2_parser.la \
+ $(top_builddir)/src/core/engine/libaxis2_engine.la \
+ $(top_builddir)/src/core/transport/http/common/libaxis2_http_common.la \
+ $(top_builddir)/neethi/src/libneethi.la
+
+INCLUDES = -I$(top_builddir)/src/xml/guththila \
+ -I$(top_builddir)/include \
+ -I$(top_builddir)/src/core/description \
+ -I$(top_builddir)/src/core/deployment \
+ -I$(top_builddir)/src/core/engine \
+ -I ../../../util/include \
+ -I ../../../axiom/include \
+ -I ../../../neethi/include
+