summaryrefslogtreecommitdiffstats
path: root/test/core/transport/http/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/core/transport/http/Makefile.am')
-rw-r--r--test/core/transport/http/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/core/transport/http/Makefile.am b/test/core/transport/http/Makefile.am
new file mode 100644
index 0000000..34eeefe
--- /dev/null
+++ b/test/core/transport/http/Makefile.am
@@ -0,0 +1,21 @@
+TESTS = test_http_transport
+check_PROGRAMS = test_http_transport
+noinst_PROGRAMS = test_http_transport
+SUBDIRS =
+AM_CFLAGS = -g -pthread
+test_http_transport_SOURCES = test_http_transport.c
+
+test_http_transport_LDADD = \
+ $(LDFLAGS) \
+ ../../../../util/src/libaxutil.la \
+ ../../../../axiom/src/om/libaxis2_axiom.la \
+ $(top_builddir)/neethi/src/libneethi.la \
+ ../../../../axiom/src/parser/$(WRAPPER_DIR)/libaxis2_parser.la \
+ $(top_builddir)/src/core/engine/libaxis2_engine.la \
+ $(top_builddir)/src/core/transport/http/sender/libaxis2_http_sender.la
+
+INCLUDES = -I${CUTEST_HOME}/include \
+ -I$(top_builddir)/include \
+ -I ../../../../util/include \
+ -I ../../../../axiom/include
+