summaryrefslogtreecommitdiffstats
path: root/tools/tcpmon/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tools/tcpmon/configure.ac')
-rw-r--r--tools/tcpmon/configure.ac17
1 files changed, 10 insertions, 7 deletions
diff --git a/tools/tcpmon/configure.ac b/tools/tcpmon/configure.ac
index 6b90909..5619c87 100644
--- a/tools/tcpmon/configure.ac
+++ b/tools/tcpmon/configure.ac
@@ -1,27 +1,30 @@
dnl run autogen.sh to generate the configure script.
-AC_PREREQ(2.63)
+AC_PREREQ(2.59)
-AC_INIT([tcpmon-src],[1.6.0])
-AC_CANONICAL_TARGET
-AC_CONFIG_HEADERS([config.h])
+AC_INIT(tcpmon-src, 1.6.0)
+AC_CANONICAL_SYSTEM
+AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AC_PREFIX_DEFAULT(/usr/local/tcpmon)
dnl Checks for programs.
AC_PROG_CC
+AC_PROG_CXX
AC_PROG_CPP
-LT_INIT
+AC_PROG_LIBTOOL
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE -g"
if test "$GCC" = "yes"; then
- CFLAGS="$CFLAGS -ansi -Wall -Wno-implicit-function-declaration -g"
+ CFLAGS="$CFLAGS -ansi -Wall -Wno-implicit-function-declaration"
fi
+LDFLAGS="$LDFLAGS -lpthread"
+
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([stdio.h stdlib.h string.h])