summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar snowdrop2004-01-06 08:02:07 +0000
committerGravatar snowdrop2004-01-06 08:02:07 +0000
commit9f89c0462109bafa8c79d40275e368c72cb67301 (patch)
treef6366a3a21315f1324f04f92524c6d26e8467a57 /configure.ac
parent1580e51bc3f3438454a4574ca121c5f44ea39acb (diff)
downloadcsoap-9f89c0462109bafa8c79d40275e368c72cb67301.tar.gz
csoap-9f89c0462109bafa8c79d40275e368c72cb67301.tar.bz2
added LIBSOCKET and LIBNSL
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a51cae9..cc42cb1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,14 @@ AC_CHECK_FUNCS([gethostbyname socket])
AC_CHECK_TYPE(ssize_t, int)
+# ------------------------------------------
+dnl Check socket library (for Solaris)
+# ------------------------------------------
+AC_CHECK_LIB(socket, socket, [LIBSOCKET="-lsocket"])
+AC_SUBST(LIBSOCKET)
+AC_CHECK_LIB(nsl, gethostbyname, [LIBNSL="-lnsl"])
+AC_SUBST(LIBNSL)
+
dnl
dnl The following new parameters were added to offer
dnl the ability to specify the location of the libxml