summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7c00430..0ae5f21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ AC_LANG_C
AC_PROG_CC
AC_PROG_AWK
AC_PROG_INSTALL
-AC_PROG_LIBTOOL
+LT_INIT(win32-dll)
dnl
dnl release and version information
@@ -73,6 +73,17 @@ AC_CHECK_LIB(uuid, uuid_create, [LIBUUID="-luuid"])
AC_CHECK_FUNCS([uuid_to_string, uuid_create])
AC_SUBST(LIBUUID)
+dnl
+dnl check host dependend flags
+dnl
+LIB_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-mingw*|*-*-cygwin*)
+ LIB_EXTRA_LDFLAGS="-no-undefined"
+ ;;
+esac
+AC_SUBST(LIB_EXTRA_LDFLAGS)
+
dnl @synopsis ACX_PTHREAD([ACTION-IF-FOUND[, ACTION-IF-NOT-FOUND]])
dnl
dnl @summary figure out how to build C programs using POSIX threads