summaryrefslogtreecommitdiffstats
path: root/examples/csoap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/csoap/Makefile.am')
-rw-r--r--examples/csoap/Makefile.am17
1 files changed, 2 insertions, 15 deletions
diff --git a/examples/csoap/Makefile.am b/examples/csoap/Makefile.am
index 386bbe9..9cecda6 100644
--- a/examples/csoap/Makefile.am
+++ b/examples/csoap/Makefile.am
@@ -1,28 +1,15 @@
+LDADD=../../nanohttp/libnanohttp.la ../../libcsoap/libcsoap.la -lpthread
+
noinst_PROGRAMS=simpleclient simpleserver echoattachments-client echoattachments-server
bin_PROGRAMS=soapclient
-INCLUDES=-I$(top_srcdir)/ $(LIBXML_CFLAGS)
-csoap_LDFLAG=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION) \
- $(LIBSOCKET) $(LIBNSL) -lpthread\
- -L$(top_builddir)/libcsoap/ -lcsoap-$(GENERIC_API_VERSION) $(LIBS)\
- $(LIBXML_LIBS)
-
simpleclient_SOURCES=simpleclient.c
-simpleclient_LDFLAGS=$(csoap_LDFLAG)
simpleserver_SOURCES=simpleserver.c
-simpleserver_LDFLAGS=$(csoap_LDFLAG)
echoattachments_server_SOURCES=echoattachments-server.c
-echoattachments_server_LDFLAGS=$(csoap_LDFLAG)
echoattachments_client_SOURCES=echoattachments-client.c
-echoattachments_client_LDFLAGS=$(csoap_LDFLAG)
soapclient_SOURCES=soapclient.c
-soapclient_LDFLAGS=$(csoap_LDFLAG)
-
-
-
-