summaryrefslogtreecommitdiffstats
path: root/examples/nanohttp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/nanohttp/Makefile.am')
-rw-r--r--examples/nanohttp/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/examples/nanohttp/Makefile.am b/examples/nanohttp/Makefile.am
index 4ade27e..8e4f7cc 100644
--- a/examples/nanohttp/Makefile.am
+++ b/examples/nanohttp/Makefile.am
@@ -1,23 +1,23 @@
bin_PROGRAMS=httpget httpgetcb httppost httpcpost postserver
INCLUDES=-I$(top_srcdir)/
-LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION) \
+nanohttp_LDFLAG=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION) \
$(LIBSOCKET) $(LIBNSL) -lpthread
httpget_SOURCES=httpget.c
-httpget_LDFLAGS=$(LDFLAGS)
+httpget_LDFLAGS=$(nanohttp_LDFLAG)
httpgetcb_SOURCES=httpgetcb.c
-httpgetcb_LDFLAGS=$(LDFLAGS)
+httpgetcb_LDFLAGS=$(nanohttp_LDFLAG)
httppost_SOURCES=httppost.c
-httppost_LDFLAGS=$(LDFLAGS)
+httppost_LDFLAGS=$(nanohttp_LDFLAG)
httpcpost_SOURCES=httpcpost.c
-httpcpost_LDFLAGS=$(LDFLAGS)
+httpcpost_LDFLAGS=$(nanohttp_LDFLAG)
postserver_SOURCES=postserver.c
-postserver_LDFLAGS=$(LDFLAGS)
+postserver_LDFLAGS=$(nanohttp_LDFLAG)