summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar mszulecki2007-02-21 17:18:01 +0000
committerGravatar mszulecki2007-02-21 17:18:01 +0000
commitbab430316c0c5b88a59c1145a92c55bb55c7da11 (patch)
tree50b07e4dea9bc023b2cf0f91775c4cac9eac0362 /configure.ac
parent83283f521dd59e3f5a4c4dda3ae61a6db4406684 (diff)
downloaddskel-bab430316c0c5b88a59c1145a92c55bb55c7da11.tar.gz
dskel-bab430316c0c5b88a59c1145a92c55bb55c7da11.tar.bz2
First attempt at an autotools D helloworld.
git-svn-id: http://svn.sukimashita.com/repos/dskel/trunk@2 4281df72-ff29-0410-8fee-2d9ac0c5f5a7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..01a7375
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,43 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(README)
+
+PACKAGE=helloworld
+VERSION=1.0.0
+
+AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
+AM_MAINTAINER_MODE
+
+AC_GNU_SOURCE
+
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+
+dnl Check for GNU D Compiler
+CC=gdc
+AC_PATH_PROG(GDC, $CC, no)
+
+if test "x$GDC" = "xno"; then
+ AC_MSG_ERROR([No D compiler found])
+fi
+
+AC_SUBST(GDC)
+
+dnl TODO: Check for duit GTK+ D Bindings
+AC_SUBST(DEPS_CFLAGS)
+AC_SUBST(DEPS_LIBS)
+
+AC_CONFIG_FILES([
+Makefile
+src/Makefile
+])
+
+AC_OUTPUT()
+
+dnl Configuration Summary
+echo ""
+echo "Configuration summary"
+echo ""
+echo " * Installation prefix = $prefix"
+echo " * D compiler: $GDC"
+echo ""