summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 520df7e..10ed9b5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,11 +1,12 @@
-SUFFIXES= .d
-
-.d.o:
- $(GDC) $(DFLAGS) -c -o $@ $<
+SUFFIXES: .d
bin_PROGRAMS = helloworld
-helloworld_SOURCES = helloworld.d
+helloworld_SOURCES = helloworld.d
helloworld_LDADD = $(DEPS_LIBS)
+helloworld_LINK = $(GDC) -o helloworld
AM_CPPFLAGS = $(DEPS_CFLAGS)
+
+.d.o:
+ $(GDC) -c -o $@ $<