summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 10ed9b5..48a7307 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,4 +9,7 @@ helloworld_LINK = $(GDC) -o helloworld
AM_CPPFLAGS = $(DEPS_CFLAGS)
.d.o:
- $(GDC) -c -o $@ $<
+ $(GDC) $(DFLAGS) -c -o $@ $<
+.d.so:
+ $(GDC) $(DFLAGS) -c -shared -fPIC -o $@ $<
+