summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c68ffec..2a97177 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,17 +1,18 @@
-SUFFIXES: .d
+noinst_LIBRARIES = libtestlibrary.a
+libtestlibrary_a_SOURCES = testlibrary.d
+libtestlibrary_a_LDFLAGS = -static
bin_PROGRAMS = helloworld
-
helloworld_SOURCES = helloworld.d
-helloworld_LDADD = $(DEPS_LIBS)
-helloworld_LINK = $(GDC) $(DFLAGS) -o helloworld $(top_srcdir)/config.d
+helloworld_LDADD = $(DEPS_LIBS) $(top_srcdir)/config.d libtestlibrary.a
+helloworld_LINK = $(GDC) $(DFLAGS) -o $@
-AM_CPPFLAGS = $(DEPS_CFLAGS)
+DFLAGS = -I$(top_srcdir) -I$(srcdir)
.d.o:
- $(GDC) $(DFLAGS) -I$(top_srcdir) -c -o $@ $<
+ $(GDC) $(DFLAGS) -c -o $@ $<
.d.so:
- $(GDC) $(DFLAGS) -I$(top_srcdir) -c -shared -fPIC -o $@ $<
+ $(GDC) $(DFLAGS) -c -shared -fPIC -o $@ $<
DISTCLEANFILES = \
Makefile.in