summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 947351c..6a4689b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,9 +6,12 @@ noinst_LIBRARIES = libtestlibrary.a
libtestlibrary_a_SOURCES = testlibrary.d
bin_PROGRAMS = helloworld
-helloworld_SOURCES = helloworld.d catalog.d
+helloworld_SOURCES = helloworld.d catalog.d testshlibrary.d
helloworld_LDADD = $(DEPS_LIBS) $(top_srcdir)/config.d libtestlibrary.a libtestshlibrary.la
-helloworld_LINK = $(GDC) $(DFLAGS) -o $@
+# It seems by overriding the _LINK primary, libtool is not called correctly
+# Requires fixing in the libtool macros/scripts
+CC=gdc
+#helloworld_LINK = $(GDC) $(DFLAGS) -o $@
DFLAGS += -I$(top_srcdir) -I$(srcdir)