summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2a97177..84f04c3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,13 +1,16 @@
+lib_LTLIBRARIES = libtestshlibrary.la
+libtestshlibrary_la_SOURCES = testshlibrary.d
+libtestshlibrary_la_LDFLAGS = -version-info 0:1:0 -module
+
noinst_LIBRARIES = libtestlibrary.a
libtestlibrary_a_SOURCES = testlibrary.d
-libtestlibrary_a_LDFLAGS = -static
bin_PROGRAMS = helloworld
helloworld_SOURCES = helloworld.d
-helloworld_LDADD = $(DEPS_LIBS) $(top_srcdir)/config.d libtestlibrary.a
+helloworld_LDADD = $(DEPS_LIBS) $(top_srcdir)/config.d libtestlibrary.a libtestshlibrary.la
helloworld_LINK = $(GDC) $(DFLAGS) -o $@
-DFLAGS = -I$(top_srcdir) -I$(srcdir)
+DFLAGS += -I$(top_srcdir) -I$(srcdir)
.d.o:
$(GDC) $(DFLAGS) -c -o $@ $<