summaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2009-03-19 22:52:58 +0100
committerGravatar Martin Szulecki2009-03-19 22:52:58 +0100
commit2a7a82094d50b75380b9858eae5eb41ed169378d (patch)
tree48e84c870df9a5211de593911d36524cf5913821 /data/icons/Makefile.am
downloadgfax-2a7a82094d50b75380b9858eae5eb41ed169378d.tar.gz
gfax-2a7a82094d50b75380b9858eae5eb41ed169378d.tar.bz2
Initial import of gfax 0.7.7
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..714218d
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,16 @@
+
+SUBDIRS = 16x16 48x48 scalable
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+clean-local :
+ rm -f *~