summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2014-05-27 11:34:18 +0200
committerGravatar Martin Szulecki2014-05-27 11:34:18 +0200
commit5fbd3251e9ab03be952a876f261ca466398c1696 (patch)
treedc682f87a474113e82dbb1e25c5f966f5d60ecc5 /configure.ac
parentf6fc79344487ac8e1f335fb86e0fb71c316f94a2 (diff)
downloadideviceinstaller-5fbd3251e9ab03be952a876f261ca466398c1696.tar.gz
ideviceinstaller-5fbd3251e9ab03be952a876f261ca466398c1696.tar.bz2
Add support for installing from directories which contain symlinks
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11f24b4..0529da5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,25 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
+# Check for lstat
+
+AC_MSG_CHECKING([whether lstat is available])
+AC_TRY_LINK([
+#include <sys/types.h>
+#include <sys/stat.h>
+#if defined(HAVE_UNISTD_H)
+#include <unistd.h>
+#endif
+],[
+struct stat st;
+lstat("/tmp", &st);
+], [have_lstat="yes"], [have_lstat="no"])
+AC_MSG_RESULT([${have_lstat}])
+
+if test "x${have_lstat}" = "xyes" ; then
+ AC_DEFINE([HAVE_LSTAT], 1, [Define if lstat syscall is supported])
+fi
+
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -Werror -g")
AC_SUBST(GLOBAL_CFLAGS)