summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-06-30 11:32:29 +0200
committerGravatar Nikias Bassen2023-06-30 11:32:29 +0200
commit835e626f1413a520093a5f1fa5c797016c13d80f (patch)
treefed61026e429bf8fa5f55f9e2da076ad3c3061b5 /configure.ac
parent9f9de528fe930f5248ed996659fdf5c22974928e (diff)
downloadideviceinstaller-835e626f1413a520093a5f1fa5c797016c13d80f.tar.gz
ideviceinstaller-835e626f1413a520093a5f1fa5c797016c13d80f.tar.bz2
Updated deprecated autoconf macros
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 3e41809..be124b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.68)
+AC_PREREQ([2.68])
AC_INIT([ideviceinstaller], [m4_esyscmd(./git-version-gen $RELEASE_VERSION)], [https://github.com/libimobiledevice/ideviceinstaller/issues], [], [https://libimobiledevice.org])
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip check-news])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
@@ -25,7 +25,6 @@ PKG_CHECK_MODULES(libplist, libplist-2.0 >= 2.3.0)
PKG_CHECK_MODULES(libzip, libzip >= 0.10)
# Checks for header files.
-AC_HEADER_STDC
AC_CHECK_HEADERS([stdint.h stdlib.h string.h])
# Checks for typedefs, structures, and compiler characteristics.
@@ -44,16 +43,16 @@ AC_CHECK_FUNCS([strdup strerror asprintf vasprintf])
# Check for lstat
AC_MSG_CHECKING([whether lstat is available])
-AC_TRY_LINK([
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#include <sys/types.h>
#include <sys/stat.h>
#if defined(HAVE_UNISTD_H)
#include <unistd.h>
#endif
-],[
+]],[[
struct stat st;
lstat("/tmp", &st);
-], [have_lstat="yes"], [have_lstat="no"])
+]])], [have_lstat="yes"], [have_lstat="no"])
AC_MSG_RESULT([${have_lstat}])
if test "x${have_lstat}" = "xyes" ; then