summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-02-11 02:31:49 +0100
committerGravatar Nikias Bassen2023-02-11 02:31:49 +0100
commitbbc82c7d5f5ffa321cc396808ed6861b89b54dd8 (patch)
tree4532f0075c881abac11f0cb7be0a09277c2e5fdd /configure.ac
parent7fbc6d180105b798af619c7994ed271cede2559e (diff)
downloadideviceinstaller-bbc82c7d5f5ffa321cc396808ed6861b89b54dd8.tar.gz
ideviceinstaller-bbc82c7d5f5ffa321cc396808ed6861b89b54dd8.tar.bz2
Update deprecated autoconf macros and automatically derive version number from latest git tag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 39e78f5..0332df3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,18 +1,23 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.64)
-AC_INIT([ideviceinstaller], [1.1.2], [https://github.com/libimobiledevice/ideviceinstaller/issues],, [https://libimobiledevice.org])
+AC_PREREQ(2.68)
+AC_INIT([ideviceinstaller], [m4_esyscmd(./git-version-gen $RELEASE_VERSION)], [https://github.com/libimobiledevice/ideviceinstaller/issues], [], [https://libimobiledevice.org])
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip check-news])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
AC_CONFIG_SRCDIR([src/])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
+# Check if we have a version defined
+if test -z $PACKAGE_VERSION; then
+ AC_MSG_ERROR([PACKAGE_VERSION is not defined. Make sure to configure a source tree checked out from git or that .tarball-version is present.])
+fi
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-AC_PROG_LIBTOOL
+LT_INIT
# Checks for libraries.
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= 1.3.0)
@@ -60,11 +65,12 @@ AC_SUBST(GLOBAL_CFLAGS)
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
src/Makefile
man/Makefile
])
+AC_OUTPUT
echo "
Configuration for $PACKAGE $VERSION: