summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2022-04-15 01:02:13 +0200
committerGravatar Nikias Bassen2022-04-15 01:02:13 +0200
commit0b269e6ee66d3aafba14b3e48f27446086f09b64 (patch)
tree7796515c0a1aa6fa4310feb3091f0b5c4b4d4d73 /configure.ac
parent6a16d60c4d0cc471d33457e90a97ba2e8b410be2 (diff)
downloadidevicerestore-0b269e6ee66d3aafba14b3e48f27446086f09b64.tar.gz
idevicerestore-0b269e6ee66d3aafba14b3e48f27446086f09b64.tar.bz2
configure: Only check for pthread if really required
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d9f9023..3815275 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,15 +87,19 @@ case ${host_os} in
darwin*)
AC_MSG_RESULT([${host_os}])
AC_DEFINE([_DARWIN_BETTER_REALPATH], [1], [Use better method for realpath])
- AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build $PACKAGE])])
;;
*)
AC_MSG_RESULT([${host_os}])
- AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build $PACKAGE])])
;;
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
+if test x$win32 != xtrue; then
+ if test "x$ac_cv_func_mkstemp" != xyes; then
+ AC_CHECK_LIB(pthread, [pthread_self], [], [AC_MSG_ERROR([pthread is required to build $PACKAGE])])
+ fi
+fi
+
CACHED_CFLAGS="$CFLAGS"
CFLAGS+=" $libimobiledevice_CFLAGS"