summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2020-06-02 03:23:07 +0200
committerGravatar Nikias Bassen2020-06-02 03:23:07 +0200
commit571e9645410482e74714e5089048682e05b3d3f8 (patch)
treef2309cc8cabdb9e681623ae1c7df75f921daf0e8 /src/Makefile.am
parent8036f3f227211fdff18cbbf85ab84f45a44c5add (diff)
downloadidevicerestore-571e9645410482e74714e5089048682e05b3d3f8.tar.gz
idevicerestore-571e9645410482e74714e5089048682e05b3d3f8.tar.bz2
Make OpenSSL dependency optional (used for SHA1)
Can be disabled with --without-openssl, otherwise auto-detected.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a27f961..1dfbc86 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,6 +24,9 @@ AM_LDADD = $(AC_LDADD)
bin_PROGRAMS = idevicerestore
idevicerestore_SOURCES = idevicerestore.c common.c tss.c fls.c mbn.c img3.c img4.c ftab.c ipsw.c normal.c dfu.c recovery.c restore.c asr.c fdr.c limera1n.c download.c locking.c socket.c thread.c jsmn.c json_plist.c
+if USE_INTERNAL_SHA1
+ idevicerestore_SOURCES += sha1.c
+endif
idevicerestore_CFLAGS = $(AM_CFLAGS)
idevicerestore_LDFLAGS = $(AM_LDFLAGS)
idevicerestore_LDADD = $(AM_LDADD)