summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2021-05-28 03:02:23 +0200
committerGravatar Nikias Bassen2021-05-28 03:02:23 +0200
commite18af8e80d71bd0f87915e64be66071d0379be38 (patch)
tree8ca2bf2282293547d1fe7f40410589c353b3de1a /src/Makefile.am
parentab6592861713fcae4d3c3d831ae75394e6262582 (diff)
downloadidevicerestore-e18af8e80d71bd0f87915e64be66071d0379be38.tar.gz
idevicerestore-e18af8e80d71bd0f87915e64be66071d0379be38.tar.bz2
Add SHA384 (and SHA512) implementation for use when compiling without OpenSSL
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ace33d4..0cfae21 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -48,8 +48,8 @@ idevicerestore_SOURCES = \
thread.c thread.h \
jsmn.c jsmn.h \
json_plist.c json_plist.h
-if USE_INTERNAL_SHA1
-idevicerestore_SOURCES += sha1.c sha1.h
+if USE_INTERNAL_SHA
+idevicerestore_SOURCES += sha1.c sha1.h sha512.c sha512.h fixedint.h
endif
idevicerestore_CFLAGS = $(AM_CFLAGS)
idevicerestore_LDFLAGS = $(AM_LDFLAGS)