summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9fcb91..e216535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,18 @@ if test x$ac_cv_func_strsep != xyes; then
fi
fi
+# check if libimobiledevice has timeout errors
+AC_CACHE_CHECK(for IDEVICE_E_TIMEOUT in enum idevice_error_t, ac_cv_idevice_error_has_timeout,
+ AC_TRY_COMPILE([
+ #include <libimobiledevice/libimobiledevice.h>
+ ], [
+ return IDEVICE_E_TIMEOUT;
+ ], ac_cv_idevice_error_has_timeout=yes, ac_cv_idevice_error_has_timeout=no))
+
+if test "$ac_cv_idevice_error_has_timeout" = "yes"; then
+ AC_DEFINE(HAVE_IDEVICE_E_TIMEOUT, 1, [Define if enum idevice_error_t defines IDEVICE_E_TIMEOUT])
+fi
+
AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(AC_LDFLAGS)
AC_SUBST(AC_LDADD)