summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-04-30 21:02:06 +0200
committerGravatar Nikias Bassen2023-04-30 21:02:06 +0200
commit067c439e0b18d6f1c8a37dde791f9d91191a922e (patch)
tree0cbb4cff978b21db27b943de9e6d5fc42cfc79e8 /Makefile.am
parent1be78391da2ce39fbf3971226ef643042b75fffd (diff)
downloadlibideviceactivation-067c439e0b18d6f1c8a37dde791f9d91191a922e.tar.gz
libideviceactivation-067c439e0b18d6f1c8a37dde791f9d91191a922e.tar.bz2
autoconf: Automatically derive version number from latest git tag
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 206c0d8..c4ed95a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,9 +3,13 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src include tools man
EXTRA_DIST = \
- README.md
+ README.md \
+ git-version-gen
DISTCHECK_CONFIGURE_FLAGS =
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
indent:
indent -kr -ut -ts4 -l120 src/*.c src/*.h dev/*.c