summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorGravatar Federico Mena Quintero2013-06-28 20:02:20 -0500
committerGravatar Federico Mena Quintero2013-07-02 20:31:44 -0500
commit42892465d4522cf19283b8a06bf48104bb387430 (patch)
treecdb38bd51c5bdc3ab65541071b70b566be3a11d5 /common/Makefile.am
parentef73e32751e86eca9ae34160708233da401a3297 (diff)
downloadlibimobiledevice-42892465d4522cf19283b8a06bf48104bb387430.tar.gz
libimobiledevice-42892465d4522cf19283b8a06bf48104bb387430.tar.bz2
common: Add utils.[ch] with a string_concat() function
Instead of doing malloc() and repeated strcat(), which is an O(n^2) way to concatenate multiple strings, we define a single O(total_len) function that uses stpcpy(). This will also make the rest of the code more legible and safer.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 664e13b..20bfe4d 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -10,7 +10,8 @@ libinternalcommon_la_SOURCES = \
socket.c socket.h \
thread.c thread.h \
debug.c debug.h \
- userpref.c userpref.h
+ userpref.c userpref.h \
+ utils.c utils.h
if WIN32
libinternalcommon_la_LIBADD += -lole32