summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-02-21 23:09:39 +0100
committerGravatar Martin Szulecki2013-02-21 23:09:39 +0100
commit4443e2fd95a71840109e7ca6d34f03e7c87dc6f8 (patch)
treebd625bc3943a0b2b5a3c7b4c9b9aa83081fe28ba /configure.ac
parent619daa992589ccfb4b44bdb4c74d5aadc7ad1f66 (diff)
downloadlibimobiledevice-4443e2fd95a71840109e7ca6d34f03e7c87dc6f8.tar.gz
libimobiledevice-4443e2fd95a71840109e7ca6d34f03e7c87dc6f8.tar.bz2
Link with ole32 on WIN32 to fix build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c4722f..b60548f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,22 @@ if test "x$ac_cv_have_endian" = "xno"; then
fi
fi
+# Check for operating system
+AC_MSG_CHECKING([whether to enable WIN32 build settings])
+case ${host_os} in
+ *mingw32*|*cygwin*)
+ win32=true
+ AC_MSG_RESULT([yes])
+ AC_CHECK_TOOL([WINDRES], [windres], AC_MSG_ERROR([windres not found]))
+ AC_SUBST(WINDRES)
+ ;;
+ *)
+ win32=false
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
+
# Cython Python Bindings
AC_ARG_WITH([cython],
[AS_HELP_STRING([--without-cython],